apkbuilds @ 8ceab0a8599974c3ed0e875354bd3c95a8c845cb

 1# Maintainer: psykose <alice@ayaya.dev>
 2pkgname=py3-jsonpickle
 3pkgver=3.0.1
 4pkgrel=1
 5pkgdesc="Serializing any arbitrary object graph into JSON"
 6url="https://pypi.org/project/jsonpickle/"
 7arch="noarch"
 8license="BSD-3-Clause"
 9depends="python3"
10makedepends="py3-gpep517 py3-setuptools py3-setuptools_scm py3-wheel"
11checkdepends="py3-pytest py3-numpy py3-pandas"
12source="https://files.pythonhosted.org/packages/source/j/jsonpickle/jsonpickle-$pkgver.tar.gz
13	noaddopts.patch
14	"
15builddir="$srcdir/jsonpickle-$pkgver"
16
17replaces="py-jsonpickle" # Backwards compatibility
18provides="py-jsonpickle=$pkgver-r$pkgrel" # Backwards compatibility
19
20build() {
21	gpep517 build-wheel \
22		--wheel-dir dist \
23		--output-fd 3 3>&1 >&2
24}
25
26check() {
27	python3 -m venv --clear --without-pip --system-site-packages testenv
28	testenv/bin/python3 -m installer dist/*.whl
29	# no gmpy
30	testenv/bin/python3 -m pytest --deselect tests/ecdsa_test.py
31}
32
33package() {
34	python3 -m installer -d "$pkgdir" \
35		dist/*.whl
36}
37
38sha512sums="
3988634acb751a0bac2c9d2ca9872dd92aeab3245ec7c1b0dced0272dc9104923b2143898fd3f7f2666bd2b220ab2396e0b2f065853256b5995695ca56534a5ea5  jsonpickle-3.0.1.tar.gz
404e95e2abd347cf221c33e919dba9cbe0886ae18c76e1ef221e0764d05e6f0e8d80731c9d84a0e0ddee94a9638784415a61bab2986d46ea54f7c9d5dc8e1226e1  noaddopts.patch
41"