1# Maintainer: Gabriel Arakaki Giovanini <mail@gabrielgio.me>
2pkgname=reddit-importer
3pkgver=0_git20231225
4pkgrel=0
5_commit=e5ce82abf59dc28bcc84a336053a95a58cf27c16
6pkgdesc="A process to import images and videos from liked post on reddit local folder."
7url="https://git.sr.ht/~gabrielgio/reddit-importer"
8arch="x86_64"
9license="MIT"
10options="!check" # this can't be tested
11depends="
12 gallery-dl
13"
14makedepends="go make"
15builddir="$srcdir/$pkgname-$_commit"
16install="$pkgname.pre-install"
17subpackages="$pkgname-openrc"
18source="$pkgname-$_commit.tar.gz::https://git.sr.ht/~gabrielgio/$pkgname/archive/$_commit.tar.gz
19 $pkgname.initd
20 $pkgname.confd"
21
22
23build() {
24 make
25}
26
27package() {
28 install -m755 -D "$srcdir"/$pkgname.initd \
29 "$pkgdir"/etc/init.d/$pkgname
30 install -m644 -D "$srcdir"/$pkgname.confd \
31 "$pkgdir"/etc/conf.d/$pkgname
32 install -Dm755 bin/reddit-importer "$pkgdir"/usr/bin/reddit-importer
33}
34
35sha512sums="
3606cbe8dc28737b4f3fa265f4af1d0dd82e2e0ad8e15e7b0efec3de6e56a7677cf9d61d82100b777a8238331bb31d98b61a427e0c9899ce391e191fcc8d765d85 reddit-importer-e5ce82abf59dc28bcc84a336053a95a58cf27c16.tar.gz
378d992bbcf8d0b9f54ce7659c9c6d27dc886b488432daad0c0857e31b006cc54b11096e056d996bb4d831babf72306e274a24a4ab77a904fa7dcf0430875e597f reddit-importer.initd
38d277a7144b89a1f100c7f2fe2a645b16ddfdcfd23ee594d24d171fc2965c342f8fce5aabff2f9ca40905d4ad7272daa586c7c8bbdf98711e627f511b07306695 reddit-importer.confd
39"