apkbuilds @ 41f77647b4a8f9430e4a61fa46e30c706c137f10

 1# Maintainer: Gabriel A. Giovanini <mail@gabriegio.me>
 2pkgname=qtc
 3pkgver=1.7.0
 4pkgrel=1
 5pkgdesc="Template compiler (converter) for quicktemplate"
 6url="https://github.com/valyala/quicktemplate/tree/master"
 7arch="x86_64"
 8license="MIT"
 9makedepends="go"
10source="$pkgname-$pkgver.tar.gz::https://github.com/valyala/quicktemplate/archive/refs/tags/v$pkgver.tar.gz"
11builddir="$srcdir/quicktemplate-$pkgver"
12
13build() {
14    go build ./qtc/main.go
15}
16
17check() {
18	go test ./...
19}
20
21package() {
22	install -Dm755 main "$pkgdir"/usr/bin/qtc
23}
24
25sha512sums="
26b7f700bafcb63d7c86741579234a32b470aa671993235ea2806545f8a4e3cf23c4464489b73af08ce2e0d8ec2185dadb24e3d73f47403d7cd02b0da9f46497da  qtc-1.7.0.tar.gz
27"