apkbuilds @ 30c9446248cbf80e8e41c75d852ae0e39cbd71e0

 1# Maintainer: Gabriel A. Giovanini <mail@gabriegio.me>
 2pkgname=qtc
 3pkgver=1.7.0
 4pkgrel=1
 5pkgdesc="Template compiler (converter) for quicktemplate"
 6url="https://github.com/valyala/quicktemplate/tree/master"
 7arch="x86_64"
 8license="MIT"
 9makedepends="go"
10source="$pkgname-$pkgver.tar.gz::https://github.com/valyala/quicktemplate/archive/refs/tags/v$pkgver.tar.gz"
11builddir="$srcdir/quicktemplate-$pkgver"
12options="!check" # disabled for now
13
14build() {
15    go build ./qtc/main.go
16}
17
18#check() {
19#	go test ./...
20#}
21
22package() {
23	install -Dm755 main "$pkgdir"/usr/bin/qtc
24}
25
26sha512sums="
27b7f700bafcb63d7c86741579234a32b470aa671993235ea2806545f8a4e3cf23c4464489b73af08ce2e0d8ec2185dadb24e3d73f47403d7cd02b0da9f46497da  qtc-1.7.0.tar.gz
28"