apkbuilds @ 3.21

 1# Maintainer: Gabriel A. Giovanini <mail@gabriegio.me>
 2pkgname=qtc
 3pkgver=1.8.0
 4pkgrel=1
 5pkgdesc="Template compiler (converter) for quicktemplate"
 6url="https://github.com/valyala/quicktemplate/tree/master"
 7arch="x86_64"
 8license="MIT"
 9makedepends="go"
10source="$pkgname-$pkgver.tar.gz::https://github.com/valyala/quicktemplate/archive/refs/tags/v$pkgver.tar.gz"
11builddir="$srcdir/quicktemplate-$pkgver"
12options="
13    !check
14    net
15"
16
17build() {
18    go build ./qtc/main.go
19}
20
21#check() {
22#	go test ./...
23#}
24
25package() {
26	install -Dm755 main "$pkgdir"/usr/bin/qtc
27}
28
29sha512sums="
30422df3af829e6d067b5106a2cb670034ac1e9ec889cb2a1409c45d4836ecdded2f753611984b0cf5e9c0ddf957a7b51e05e0dfc981010350e23f480a6162533e  qtc-1.8.0.tar.gz
31"