1# Maintainer: Gabriel A. Giovanini <mail@gabriegio.me>
2pkgname=nextcloud-ext
3pkgver=0.0.1
4pkgrel=1
5pkgdesc="Meta package for maintaining nextcloud"
6url="https://git.sr.ht/~gabrielgio/apkbuilds"
7arch="noarch"
8license="MIT"
9options="!check" # this can't be tested
10depends="
11 nextcloud
12 nextcloud-files_external
13 nextcloud-files_pdfviewer
14 nextcloud-files_rightclick
15 nextcloud-files_sharing
16 nextcloud-files_trashbin
17 nextcloud-files_versions
18 nextcloud-files_videoplayer
19 nextcloud-initscript
20 nextcloud-pgsql
21 nextcloud-photos
22 nextcloud-sharebymail
23 nextcloud-text
24 nextcloud-user_status
25 nextcloud-weather_status
26 ffmpeg
27"
28source="$pkgname.cron"
29builddir="$srcdir"/$pkgname
30
31package() {
32 mkdir -p "$pkgdir"
33 install -m 755 -D "$srcdir"/$pkgname.cron "$pkgdir"/etc/periodic/15min/$pkgname
34}
35sha512sums="
3666b1609a3b4d8e398a37f7bda117b0b0a661d32c9484202758c0c21b18560f46bded9b17a3b4ec4931a26dd2b02a20fe5be1f06c3420da69ea952a6aa712ff5c nextcloud-ext.cron
37"